Authentification failed

Tagged:

Currently contains 4 posts

Avatar

November 24, 2017 12:41

Thomas Binder

Hi there,

I’m on the free plan and have just created my account and the corresponding Application ID and Application Key.

If I try this URL per GET:
https://api.weatherunlocked.com/api/snowreport/222037?app_id=xxx&app_key=xxx

I get as tesponse:
Authentication or authorization failed. Please check your keys or plan Limits

I already created two new App Keys and tried that ones – with the same response.

What did i do wrong? Thanks for a little help…

Avatar

November 24, 2017 12:46

Thomas Binder

just for information:

  • Microsoft Edge 10 (38.14393.1066.0)
  • Mozilla Firefox 57 (Quantum)
  • Google Chrome 62.0.3202.94
  • wget 1.18

Avatar

November 24, 2017 13:07

Thomas Binder

ok. nevermind! Got it worked out! ;)
1) You Need to have the right plan activated (in my case I thought I had something with Ski Resorts activated! but it was “only” local weather)
2) You Need to select the right datapoint (in my case the Ski Resort) in the admin
3) after having done all that, now it works!

but: I couldn’t save the Location (step 2) via the admin Dashboard, but only after reading the Response “Resort requested is not selected in the Dashboard”… I needed to follow the link also given in the Response: https://developer.weatherunlocked.com/skiresort/dashboard. This one isn’t reachable from the “dashboard” in https://developer.weatherunlocked.com/admin… Perhaps something worth adding? ;)

Avatar

November 24, 2017 13:40

John Armstrong

Hi Thomas,

Glad you’ve got it sorted. Yes, you were trying to call the Free Local Weather API using an HTTPS request – when this free plan only allows for HTTP requests.

Many thanks for your feedback regarding the Ski Resort API. We’re making changes to ensure it’s easier to navigate your way to getting returned data.

Kind regards,

John.

Reply to thread
  1. If you're human, leave this field empty.